Nouvelle discussionNouveau message Derniers messages Recherche forum
678 messages.      60 61 62 63 64 65 66 67 68   - Realisation de BMS evolutif a microprocesseurs [9645]
Complite120
23-11-2017 à 08h34
D'après ce que j'ai pu constater l'idéal serait un courant nominal fort puis qui faiblirait par palier pendant l'équilibrage au fur et à mesure de la montée en tension des cellules.
Exemple :
Début de charge 6A
Début d'équilibrage 6A/200mA
Milieu d'équilibrage 4A/200mA
Milieu d'équilibrage 2A/200mA
Fin d'équilibrage 1A/200mA

Évidemment ces paliers seraient programmables pour s'adapter aux technologies de cellules et à PTCH.
Je testerai cela lors de la prochaine charge en réglant manuellement les courants.

Anonyme, 196 msg, 60 ans. Toulouse (FR-31). Complite120 BBS02B 36V 500W batterie 10S4P DIY BMS DIY
 Citer Alerter [541200]

Message modifié le 2017-11-23 08:44:57 par Complite120.
Richardel
23-11-2017 à 11h11
Acceder au profil du membre
Je ne sais pas, la mienne est réglée à 2mV et le meilleur résultat obtenu est 4mV.


D'accord, mais il ne faut pas oublier la précision de la mesure (convertisseur A/D des pics) qui, si je me souviens bien, est de 7mv.
donc, a mon avis, tant qu'on reste dans une fourchette de 10 a 15mv, on est dans le bon.
ca doit pas affecter beaucoup l'autonomie (surtout qu'on mesure cet écart dans la partie haute de la charge)

Sur le mien la tension de coupure est inférieure de ~30mV à celle programmée


oui, mais 30mv de la tension programmée mais de laquelle ? ptch (chez moi 3.55v) ou pvequ (chez moi 3.400v).

D'après ce que j'ai pu constater l'idéal serait un courant nominal fort puis qui faiblirait par palier pendant l'équilibrage au fur et à mesure de la montée en tension des cellules.


oui, ca j'imagine mais c'est là que la théorie se heurte a la pratique... faire plusieurs paliers obligerait le MOS a dissiper de la chaleur (en plus de l'électronique plus complexe).
je pense, du reste, que c'est un peu ce que simule Jean Marc par son "PWM très lent".

En tout cas, quand on compare le temps d'équilibrage de l'algorithme 1 et de l'algorithme 5, il ne fait aucun doute que le 5 est beaucoup plus efficace... c'est saisissant... je m'attendais pas a ça.

Richard, 1120 msg, 64 ans. Petit Rechain (BE-48).
 Citer Alerter [541219]
publicité
23-11-2017 à 11h11
Lien commercial -276-


Complite120
23-11-2017 à 12h48

Richardel a écrit :
oui, mais 30mv de la tension programmée mais de laquelle ?

PTCH


Richardel a écrit :
oui, ca j'imagine mais c'est là que la théorie se heurte a la pratique... faire plusieurs paliers obligerait le MOS a dissiper de la chaleur (en plus de l'électronique plus complexe).

Je suis d'accord. Cela marche déjà très bien en l'état.

Cordialement.

Anonyme, 196 msg, 60 ans. Toulouse (FR-31). Complite120 BBS02B 36V 500W batterie 10S4P DIY BMS DIY
 Citer Alerter [541237]
Richardel
24-11-2017 à 17h11
Acceder au profil du membre
oui, complite, alors si c'est ptch, c'est super, la batterie est a son max.

Oui, ca marche très bien, même.

Par contre, je soupçonne une anomalie... Aurais-tu déjà eu, après recharge, une impossibilité de débiter dans une charge ?
ca fait 3 fois que ca m'arrive.
je recharge en pmode 5, l'équilibrage se fait, le chargeur se coupe (I=0), je déconnecte le chargeur et je connecte mes lampes de charge et là, rien... les lampes restent éteintes (et je mesure 0v sur le gate des 3 fets).
je dois déconnecter les fils d'équilibrages pour forcer un reset et là, les lampes fonctionnent.

Aurais-tu déjà constaté cette anomalie ?

Richard, 1120 msg, 64 ans. Petit Rechain (BE-48).
 Citer Alerter [541385]

Message modifié le 2017-11-24 17:13:38 par Richardel.
3615jmd
24-11-2017 à 23h33
@richard: voici la référence de tension que je vais essayer: LM4040 en SOT23 en 2.5V Mais pour les Lifepo4 il vaudra mieux choisir le LM4040 en 2.048V ou bien si tu veux descendre plus bas, le LM4041 avec ses 1.225V, mais là la résolution de la mesure de tension en prendra un coup !

attention: il existe plusieurs grades (précision) dans ces CI, autant chercher le meilleur (A-grade)

bien entendu, la tension de ref. sera paramétrable, donc on sera libre d'utiliser la tension de ref que l'on voudra. (en dessous de la tension la plus basse de la cellule bien sûr)







Jean-marc, 257 msg, 61 ans. Vieille Toulouse (FR-31). [mon blog]
 Citer Alerter [541424]
Complite120
26-11-2017 à 16h54

Richardel a écrit :

Par contre, je soupçonne une anomalie... Aurais-tu déjà eu, après recharge, une impossibilité de débiter dans une charge ?Aurais-tu déjà constaté cette anomalie ?


Oui, c'est déjà arrivé, plus d'une fois et c'est extrêmement agaçant. Pour l'instant je gère cela en deconnectant et reconnectant les câbles d'équilibrage car la batterie est encore à l'état prototype. Il faut que je trouve d’où cela vient pour pouvoir la finaliser.
Cordialement.

Anonyme, 196 msg, 60 ans. Toulouse (FR-31). Complite120 BBS02B 36V 500W batterie 10S4P DIY BMS DIY
 Citer Alerter [541617]
Richardel
26-11-2017 à 18h37
Acceder au profil du membre
Merci, Jean Marc,

les références en tension


C'est dommage que ca n'existe pas vers 1.7v mais bon, je crois que 2.048v et "couper tout" en tension cellule inférieur a 2.5v conviendra très bien.
-Je suppose que chaque pic slave aura son lm4040 ? (donc, dans mon cas, 16 lm4040 par BMS).
Bonne idée de donner la valeur en paramètres. ce sera une valeur générale ou cellule par cellule ?
bon, 0.1% ne donne quand même qu'une erreure de 2mv et si on veut mieux, rien n'empêche de faire un tri.

le soft 3.6


Au niveau du soft 3.6, j'ai un petit problème.
Aujourd'hui, j'ai vidé a peu près 1/5 de la batterie puis l'ai remise en charge (pmode5).
Celle-ci s'est bien déroulée (charge a 6A puis passage a l'équilibrage, équilibrage a courant réduit puis, un peu plus tard, arret de la charge).
J'ai ensuite déconnecter le chargeur et connecté mes lampes et là, rien... J'ai du resetter en déconnectant les fils d'équilibrage, attendre un peu puis les reconnecter. Ce n'est pas la première fois que ca m'arrive, mais ici, j'ai bien fait attention et ca confirme.
Une des fois précédentes, j'avais mesuré que le tension gate des mos de sortie était bien à 0v

Petite info, j'ai déséquilibré une cellule volontairement (et manifestement, elle réduit son écart au fil des recharges) mais ca signifie que l’arrêt de la charge s'est fait sur ptch atteinte par une cellule et non sur delta v identique.
Ne manquerait-il pas là une instruction de conduction des mos ? (les trames sont bien reçues par le maître).
J'ignore si ce problème existe quand la charge s’arrête par un équilibre des cellules.

Ca ne pose pas de problème a la saison actuelle (toutes les batteries sont a l'atelier) mais comme, a la belle saison, les batteries sont devant les roues avant, je n'ai pas accès aux fils d'équilibrages sans démonter l'avant et donc le reset après chaque recharge est particulièrement lourd.

Sinon, quelle différence avec le mode 1... saisissant.
Tu as fait, là, une amélioration fantastique.
Je crois que le BMS est capable de réduire un fort déséquilibre (celui que j'ai imposé faisait 1AH).
Au pif, j'estime qu'il sera rattrapé en une grosse dizaine de recharges maximum.


Richard, 1120 msg, 64 ans. Petit Rechain (BE-48).
 Citer Alerter [541632]
Richardel
26-11-2017 à 19h57
Acceder au profil du membre
Désolé, Complite, j'avais pas rafraichi la page...

Alors je ne suis pas le seul donc c'est pas un problème hardware (de toutes façon, a part le processeur qui commande directement les FET...)
ca confirme mon message précédent.

donc petit appel a Jean Marc


Richard, 1120 msg, 64 ans. Petit Rechain (BE-48).
 Citer Alerter [541656]
3615jmd
27-11-2017 à 10h07
Alors, avez vous regardé ce que donne la commande valcoup ? probablement que le BMS est passé en sécurité.

@ Richard: Je ne comprend d'ailleurs pas pourquoi le BMS coupe la sortie moteur en mode 5 ??? puisque lorsqu'une cellule arrive au seuil haut elle passe en équilibrage avec courant réduit, elle ne doit pas monter plus haut ! (sauf si le courant réduit est réglé plus haut que ce que consomme la résistance, ou si le seuil de coupure haute est trop prés ou au dessous du seuil d'alerte)

et pas de diode bleue ?

avez vous noté le numéro de l'état de l'automate qui est envoyé dans la trame $1 ou $BMS ?

avez vous connecté un buzzer ? (il bipe en cas d'anomalie)

Jean-marc, 257 msg, 61 ans. Vieille Toulouse (FR-31). [mon blog]
 Citer Alerter [541735]
publicité
27-11-2017 à 10h07
Accédez à notre site www.power-e-bike.fr
Lien commercial -232-

Complite120
27-11-2017 à 11h20
Effectivement la diode bleue clignotait. De mémoire j'avais des paramètres farfelus que j'ai corrigés depuis. En principe tout devrait fonctionner correctement, mais je n'ai pas refait de charge depuis.
Cordialement.

Anonyme, 196 msg, 60 ans. Toulouse (FR-31). Complite120 BBS02B 36V 500W batterie 10S4P DIY BMS DIY
 Citer Alerter [541740]

Message modifié le 2017-11-27 11:21:29 par Complite120.
678 messages.      60 61 62 63 64 65 66 67 68   - Realisation de BMS evolutif a microprocesseurs - Lu 367349 fois. [9645]
retour en haut de page Messages récents
répondre dans cette discussion
En ce moment sur le tchat
Le 02 à 18h08 Pasaub bonjour,
je suis en panne avec le petit ordi de mon VAE qui reste en noir absolu, suivant les conseils de mon vendeur je l"ai mis en...
Le 03 à 07h13 Pasaub bonjour,
je viens de me dépanner avec le petit ordi de mon VAE,sur les conseils de mon vendeur et mécanicien, a savoir mettre en...
Le 09 à 13h44 Sebastiengriet Bonjour,
Je m'appelle Sébastien.
Je suis nouveau sur ce forum et dans le monde du VAE.
Je me suis cependant lancé dans la...
Le 09 à 13h48 J0rdi bonjour à tous, je suis nouveau sur cyclurba
Le 20 à 20h07 Roolio-de-la-vega Bonjour j'ai un soucis de puissance. Je vous explique ma config : alternateur converti , contrôleur 1500w 48-64v ,4 batteries gel 12v 15ah...

Lien commercial -48-


Transformez votre vélo, en vélo électrique.

Reconditionnement batterie Lithium