Nouvelle discussionNouveau message Derniers messages Recherche forum
753 messages.      61 62 63 64 65 66 67 68 69 70 71   - Realisation de BMS evolutif a microprocesseurs [9645]
3615jmd
27-11-2017 à 17h01
@complite : ok, merci
@richard: peux tu poster ici la liste de tes paramètres (commande petit L) ?


Jean-marc, 264 msg, 61 ans. Vieille Toulouse (FR-31). [mon blog]
 Citer Alerter [541761]
Richardel
27-11-2017 à 17h11
Acceder au profil du membre
la commande valcoup ?


pas pensé, désolé (c'est vrai que je m'en sers plus souvent en limite basse... je vais essayer.)

pour le courant réduit, je l'ai réglé a 220ma (j'ai 212ma via les résistances de 33 ohms (calculé a 3.5v) + le courant de la led (5ma)) mais je peux le rabaisser un peu.

pour les diodes et le bip, je suis tombé sur le BMS qui est prévu de mettre ces deux éléments a distance (donc pas de led équipée, juste un connecteur).

avez vous noté le numéro de l'état de l'automate qui est envoyé dans la trame $1 ou $BMS ?


j'ai surveillé le courant de charge mais pas l'etat.

Demain, je change de BMS (pour avoir led et buzzer) et je recommence en faisant un copié collé des trames... A quelles étapes veux-tu que je les fasses ?
je ferais, aussi, un valcoup dès que la charge est terminée.
Je vais aussi essayer de mettre une led en sortie pour voir quand ca coupe

je viens de voir ton message, voici mes paramètres.
note que la tension d'alarme est 10mv au dessus de la coupure haute car, en pratique, je ne désire pas d'alarme a ce stade (mais je peux l'adapter pour les essais, bien sûr)

Richard, 1474 msg, 64 ans. Petit Rechain (BE-48).
 Citer Alerter [541765]

Message modifié le 2017-11-27 17:19:31 par Richardel.
publicité
27-11-2017 à 17h11
Transformez votre vélo en vélo électrique!
Lien commercial -289-


Richardel
27-11-2017 à 17h28
Acceder au profil du membre
Mais je suis bête... valcoup, il le memorise... donc le voici...
la cellule desequilibrée (au début +1AH par rapport aux autres) est la cellule 16

Richard, 1474 msg, 64 ans. Petit Rechain (BE-48).
 Citer Alerter [541767]
3615jmd
28-11-2017 à 09h56
Bon, c'est limpide, tu as programmé la coupure haute à 3550 mV, ça a coupé quand la 16 est arrivée à 3550mV. rien de plus normal !

l'erreur c'est que tu as croisé l'alerte et la coupure. Ton alerte est au DESSUS de la coupure, donc le BMS ne peut pas équilibrer, à la place il coupe direct. (La led bleue est là pour indiquer cet état)

essaye avec ptah = 3550 et ptch 3560, ça marchera bcp mieux. ne touche pas à ton courant de charge réduite, ça ne venait pas de là.

JM


Jean-marc, 264 msg, 61 ans. Vieille Toulouse (FR-31). [mon blog]
 Citer Alerter [541866]
Richardel
28-11-2017 à 10h51
Acceder au profil du membre
AHHH... tu veux donc dire que le ptah sert à autre chose que simplement activer le buzzer ?

En réalité, lorsque je travaillais, le Waw était garé dans un grand garage commun et je chargeais la batterie "sur place (dans le garage)" grâce a une prise de courant toute proche.
Pour éviter "d'alerter inutilement" les collègues, j'avais mis ce paramétrage afin que le buzzer reste muet lors de la fin de charge. (j'avais bien pensé l'enlever provisoirement mais il m'était utile en décharge).
J'ai gardé ce paramétrage.

Comme maintenant, ca n'a plus d'importance (il peut buzzer dans l'abri de jardin), je vais suivre ton conseil immédiatement.

je suis surpris que tu dise qu'il n'équilibre pas... parce que, malgré l'inversion ptch/ptah, je trouve que l’équilibrage est déjà très efficace. il dure au moins 15 fois plus longtemps que dans le mode 1. Il lui faut quand même du temps pour quitter le pvequ et atteindre le ptch grâce a tes "petits a coup" et je pense que la perte de tension des lifepo4 au repos est, ici, un avantage car ca permet de rester dans la fenêtre beaucoup plus longtemps.

Par contre, c'est la déconnexion de la sortie qui me tracasse.
Cette inversion ptah/ptch peut-elle expliquer le fait que la sortie soit coupée après recharge ? j'ai toujours pensé que atteindre le ptch coupait le chargeur mais je ne voyais pas l’intérêt d'agir sur la sortie utilisation (moteur).

bon, je change le paramétrage, je resette le bms, décharge un peu puis je réessaye (je te tiens au courant)... pour les tests, je vais agrandir un peu l'ecart... mettre ptch a 3550mv et ptah vers 3520mv.
Merci, Jean Marc

Richard, 1474 msg, 64 ans. Petit Rechain (BE-48).
 Citer Alerter [541867]
3615jmd
28-11-2017 à 15h03

Richard a écrit :
AHHH... tu veux donc dire que le ptah sert à autre chose que simplement activer le buzzer ?



Richard, voici ce que j'ai écrit dans la doc jointe avec le logiciel:

"Algo N°5 ou « équilibrage simple avec régulation »:
Cet algo est identique au N°1 avec la différence que si une cellule « monte » trop vite et
atteint le seuil d’alerte haute, au lieu de stopper bêtement la charge, le courant sera réduit
pour une période réarmable de 30 secondes. Il vaut mieux utiliser cet Algo à la place du N°1
qui devient obsolète."


Richard a écrit :
je suis surpris que tu dise qu'il n'équilibre pas...



Je voulais dire "... pas correctement" Car l'avantage du N°5 c'est de continuer l'équilibrage jusqu'à la fin, en mode charge réduite. Avec ptch plus bas que ptah, tu as transformé l'algo N°5 en N°1 avec la punition de la coupure en sus.

Jean-marc, 264 msg, 61 ans. Vieille Toulouse (FR-31). [mon blog]
 Citer Alerter [541903]
Richardel
28-11-2017 à 18h36
Acceder au profil du membre
atteint le seuil d’alerte haute, au lieu de stopper bêtement la charge, le courant sera réduit


là, je te dois des excuses... j'avais lu ce passage mais comme l'algo 1 se coupait sur ptch, j'en ai déduit que tu t'étais trompé (alerte au lieu de coupure) et qu'arrivé à ptch, le courant passait en réduit, ce qui diminuait la tension des cellules ce qui permettait un équilibrage plus long.
C'est pour ca que je ne comprenais pas cette histoire "d'a coup".


Avec ptch plus bas que ptah, tu as transformé l'algo N°5 en N°1


t'es sur ?
parce que, même avec ptch plus bas que ptah, je suis formel... il passe en courant réduit.
(maintenant ptah n'etant que 10mv au dessus de ptch, la tension a peut-être fait une excursion jusque là vu que le courant de charge est a 6A)
Je dis ca parce que sur les 6 ou 7 essais que j'ai fait, presque tous sont passés par le courant réduit. Je dis presque tous car, dans un seul cas, j'ai constaté que la charge s'était stoppée (et je me suis demandé pourquoi).

en remettant les paramètres dans le bon ordre, l'équilibrage se fait encore plus longtemps.
Le déséquilibre volontaire est maintenant résorbé.
par contre, toujours pas de jus en sortie.

voici les trames a la fin de la charge (ptch tjs a 3550mv ptah a 3520mv)

Richard, 1474 msg, 64 ans. Petit Rechain (BE-48).
 Citer Alerter [541934]
3615jmd
29-11-2017 à 11h26

Richard a écrit :
t'es sur ?

c'est pas tout à fait identique bien sûr, la coupure étant temporisée, oui il va pouvoir passer en réduit avant que ça coupe, désolé, je n'ai jamais fait de tests avec les paramètres inversés... d'ailleurs je pense que je vais mettre un test dans la prochaine version pour empêcher de mettre les seuils à l'envers.

Jean-marc, 264 msg, 61 ans. Vieille Toulouse (FR-31). [mon blog]
 Citer Alerter [542039]
Richardel
30-11-2017 à 16h22
Acceder au profil du membre
Je comprends que tu n'as pas fait les tests avec des paramètres inversés, c'est une situation anormale.
Maintenant que je comprends mieux le déroulement, c'est logique.

je viens de changer de BMS (j'ai mis celui avec leds et buzzer).
Demain, je refais une charge en surveillant la tension de sortie (voir quand elle se coupe et si elle se rétabli) et en visualisant la led.


Richard, 1474 msg, 64 ans. Petit Rechain (BE-48).
 Citer Alerter [542243]
publicité
30-11-2017 à 16h22
Kit moteur Bafang BBS02 et batterie 500 Wh
Ensemble moteur Bafang BBS02 36V500W et batterie porte bagage Alu 36V14Ah (500 Wh) avec cellules Panasonic
www.kitveloelectric-bonplan.com
Lien commercial -314-

Richardel
01-12-2017 à 17h12
Acceder au profil du membre
Bon, essais de ce jour :
avec un BMS doté des led, j'ai enlevé a peu près 2AH (sur une batterie de 12AH).
BMS paramétré comme suit.
j'ai ensuite connecté le chargeur 6A
après une fraction de seconde, la led témoin que j'ai mis sur la sortie se coupe.
la charge commence a 6A jusqu'a atteindre ptah puis commence la charge a courent réduit alterné avec des pointes de 6A.
au niveau des leds, la verte et la jaune clignote en alterné (1 sec on, 1 sec off)
je suis resté a proximité et au moment ou les leds d'équilibrage se sont coupées, le pc a affiché une série de chiffres alors que rien n'a été demandé.
de plus, la led est en clignotant bleu.

voici un copié collé du moment de la coupure (avec ce curieux "etat" des 16 cellules)

Richard, 1474 msg, 64 ans. Petit Rechain (BE-48).
 Citer Alerter [542380]
753 messages.      61 62 63 64 65 66 67 68 69 70 71   - Realisation de BMS evolutif a microprocesseurs - Lu 403114 fois. [9645]
retour en haut de page Messages récents
répondre dans cette discussion
En ce moment sur le tchat
Le 10 à 10h02 Havoc Merci d'éviter d'utiliser la tchat box pour poser des questions techniques.
Le 13 à 18h03 Havoc Thibaut Pinot vainqueur du Tour de Lombardie 2018 ! (Jalabert 1997)
Le 14 à 19h07 Seramik bonjour
je vais acheter une nouvelle batterie pour mon cargo sur alie express
y a t il des noms/ marques à éviter ou à...
Le 20 à 12h10 Damien3873 si j'ai bien compris c'est moins risqué avec des cellule de marque panasonic ou mieux samsung. Dans la boutique...
Le 20 à 12h11 Damien3873 Je cherche à emprunter sur Chambéry contre une bonne bière ou un jus de fruit, l’outil de montage bafang, le cable de prog et...

Découvrez nos produits
Lien commercial -341-