SP-2:.### Z01### Reprogrammation des BBS01 et BBS02 Forum Cyclurba.fr. Moteurs Bafang / 8FUN

Nouvelle discussionNouveau message Derniers messages Recherche forum
1718 messages.      158 159 160 161 162 163 164 165 166 167 168   - Reprogrammation des BBS01 et BBS02 [15610]
Marvan
27-12-2018 à 19h14
Acceder au profil du membre


Marc, 505 msg, 56 ans. Algodonales (ES-11).
 Citer Alerter [598119]

Message modifié le 2018-12-27 19:21:33 par Marvan.
Marvan
27-12-2018 à 19h16
Acceder au profil du membre
Je vous remets mon message mais en 5 parties. Je ne comprends pas ce qu'il ce passe. J'ai utilisés 3 appareils différents et le problème reste le même. Quand je copie et que je colle ça ne marche pas bien.

1)
En plus de ce foutu problème de bug d’accélérateur que j’ai contourné en mixant les bons conseils de Didier ( en cochant By display’s Command pour le Designated Assist Level) et de Jacques (je garde 9 niveaux mais ne me sers pour le PAS que des 5 premiers), j’en ai aussi un autre :
seul l’onglet Basic garde les modifs que je fais, la reprogrammation des onglets Pedal assist et Trottle disparaissent après avoir utilisé le vélo.

Je vous explique comment je fais. Sachez que j’utilise la même procédure avec mes 2 autres vélos (bbs02 500w 36v) plus anciens et je n’ai jamais eu de problème.

Donc, sur mon bbs02b 750w, après avoir fait une modification de la programmation, et pour chaque onglet, je clique toujours sur Write et puis sur Flash Write (j’ai toujours fait comme ça mais je ne sais pas si l’un ou l’autre est suffisant ou si les 2 sont nécessaires ?).
Après, je vérifie les 3 onglets en cliquant sur Read: tout va bien

Marc, 505 msg, 56 ans. Algodonales (ES-11).
 Citer Alerter [598120]

Message modifié le 2018-12-27 20:19:24 par Marvan.
publicité
27-12-2018 à 19h16
Lien commercial -48-


Marvan
27-12-2018 à 19h57
Acceder au profil du membre
2)
J’ai aussi testé en déconnectant le vélo de l’ordi après avoir quitté le programme de flashage, puis rouvert le programme et reconnecté le vélo sur l’ordi. Mais ceci sans reconnecter le moteur au display, ni allumer le display. Je clique Read sur chaque onglet et tout va toujours bien pour les 3 onglets

Marc, 505 msg, 56 ans. Algodonales (ES-11).
 Citer Alerter [598128]

Message modifié le 2018-12-27 20:18:51 par Marvan.
Marvan
27-12-2018 à 19h59
Acceder au profil du membre
3)
Après, je déconnecte le vélo et vais l’essayer (donc j’allume le display !!!).
Tout fonctionne comme le l’ai reprogrammé. C’est clair car suite au changement dans l’onglet du Throttle, en cochant By display’s Command pour le Designated Assist Level, l’accélérateur fonctionne en suivant les niveaux du PAS, comme Didier me l’avais indiqué. Tout semble en ordre et ça marche assez bien. C’était un bon conseil. Merci Didier

Marc, 505 msg, 56 ans. Algodonales (ES-11).
 Citer Alerter [598130]

Message modifié le 2018-12-27 20:19:44 par Marvan.
Marvan
27-12-2018 à 20h00
Acceder au profil du membre
4)
Après je reviens cool à l’ordi et reconnecte le vélo parce que je veux faire un nouveau changement. Et Là, stupeur :

Marc, 505 msg, 56 ans. Algodonales (ES-11).
 Citer Alerter [598131]

Message modifié le 2018-12-27 20:20:10 par Marvan.
Marvan
27-12-2018 à 20h13
Acceder au profil du membre
5)
L'onglet basic est ok mais les onglets Pedal Assist Level et Throttle sont revenus à la programmation d'origine !
Je retourne essayer et effectivement le vélo réagit suivant cette programmation d'origine.
J'ai testé 3 fois.
Donc, je suppose que c'est au moment ou je rebranche et allume le display que ça déraille pour les 2 onglets concernés.
Je n'ai pas essayé d'éteindre et de rallumer le display, une ou plusieurs fois, sans le rebrancher à l'ordi, pour voir si après ça le fonctionnement du moteur suis ma programmation perso ou si ça change d'office en faveur de la programmation d'origine.

Est-ce un problème connu et y a t il une solution ?

Marc, 505 msg, 56 ans. Algodonales (ES-11).
 Citer Alerter [598132]

Message modifié le 2018-12-27 20:20:24 par Marvan.
Elem
27-12-2018 à 21h53
Acceder au profil du membre
peux etre que ca vient de la 850C qui prend la main !?

Didier, 4117 msg, 58 ans. Biot (FR-06). [mon blog] VTT SWX02 RR-9.1 * VTT TSDZ2 RR-9.1 elementaire01.blogspot.com/
 Citer Alerter [598138]
Jacques74
28-12-2018 à 07h14
Acceder au profil du membre
Perso j'évite le "write flash" (qui est sensé cumuler les 3 onglets), c'est souvent capricieux et envoi que le premier onglet !
... c'était en tout cas le cas avec le premier soft Bafang, avant celui de Penov.
Probablement un problème de timing et de contrôle.

1- Je fais un simple "write" sur chaque onglet, puis en général un "read" pour être sûr que tout est ok.
2- Ensuite je déconnecte le port Com (bouton disconnect), puis la batterie et finalement le cable USB.
3- Je rebranche le display, puis je reconnecte la batterie

Jamais eu de problème de cette façon, en me tenant à ce protocole.
A noter qu'un display courant comme le P850C ne peut pas flasher le controleur et donc modifier sa prog...
sauf mon BBSDuino qui a cette possibilité, mais bon...


Ps: Tu aurais pu expliquer ton soucis dans un seul message, on aurait compris

Anonyme, 16732 msg, (FR).
 Citer Alerter [598160]
Marvan
28-12-2018 à 08h43
Acceder au profil du membre
Merci Jacques. Je testerai ça la semaine prochaine car je suis en voyage.

Marc, 505 msg, 56 ans. Algodonales (ES-11).
 Citer Alerter [598164]
publicité
28-12-2018 à 08h43
Accédez à notre site www.power-e-bike.fr
Lien commercial -232-

Sergio44
31-12-2018 à 13h27
@GIU69 Merci pour l'info à la page 160 .
je vais tester cela quand j' aurais un moment.

Anonyme, 45 msg, 59 ans. (FR-44).
 Citer Alerter [598416]
1718 messages.      158 159 160 161 162 163 164 165 166 167 168   - Reprogrammation des BBS01 et BBS02 - Lu 496762 fois. [15610]
retour en haut de page Messages récents
répondre dans cette discussion
En ce moment sur le tchat
Le 05 à 21h07 Havoc Oui, il tournera plus vite et il faudra en tenir compte.
Le 15 à 17h36 Leyo Bonjour je voudrais savoir quelle type de contrôleur je dois l'acheter pour ma trottinette électrique.
je vous rajoute la photo de...
Le 17 à 17h38 Jp-doudou bonjour a tous si je monte un badassbox 4 sur un moteur bosch irai-je plus vite en mode TOUR ? merci d'avance bonne journee .
Le 18 à 12h00 Ptit-philou Bonjour, je ne pense pas : voir la fiche du fabricant.
Il faut poser la question sur le forum ;-)
Pas assez de place et de...
Le 20 à 18h23 Havoc Oui, sur le forum, Seby. Thibaut Pinot premier ce soir en haut du Tourmalet et Alaphilippe en jaune qui décroche Thomas de 36s...

Réparer et entretenir son vélo soi-meme
Lien commercial -181-


Accédez à notre site www.power-e-bike.fr

Découvrez tous nos display compatible Bafang