Nouvelle discussionNouveau message Derniers messages Recherche forum
52 messages.      1 2 3 4 5 6   - Protocole batterie Panasonic 36V [18354]
David66
28-04-2016 à 10h39
non je ne pense pas que ça soit ça à mon avis T ne représente pas la température
c'est juste l'entrée de détection de batterie avec 3 niveaux :
* batterie absente
* batterie présente à charger
* batterie présente charge terminée

voila le fonctionnement
sans batterie sur le chargeur la sortie de charge est à 0V et T et S à 5V continus


quand on place la batterie 36V sur le chargeur, la batterie fait chuter T à 2.2V (avec environ 4kΩ à la masse) alors le chargeur sait qu'il y a une batterie et la led passe au vert ensuite il envoie sur S 3 ou 4 trames imbitables d'une vingtaine d'octets puis chaque seconde la trame $ FF FF 00 B3 4D
# si la batterie répond sur S $ FF FF 01 D3 02 2A (décidé par le BMS parce qu'il faut charger la batterie) alors la led reste verte et le chargeur active la charge sur C
# si la batterie ne répond pas sur S (bug ou pas de BMS Panasonic) au bout de quelques secondes sans réponse le chargeur clignote en rouge et n'envoie plus de trame sur S
# si la batterie a fini la charge (décidé par le BMS) alors T passe à 0.5V et la batterie répond sur S $ FF FF 01 D3 04 28 et la charge s'arréte les leds de niveau de la batterie s'éteignent et celle du chargeur aussi

David, 182 msg, 59 ans. (FR-66).
 Citer Alerter [446389]

Message modifié le 2016-04-28 10:44:03 par David66.
Olorin
28-04-2016 à 10h42
.... C'est quoi la trame imbitable

Olorin, 1756 msg, 36 ans. Massy (FR-91). [mon blog] Gitane NoCar 2012 16661km / MW-cycle BBS02 48v/750W 5260km
 Citer Alerter [446390]
publicité
28-04-2016 à 10h42
Lien commercial -276-


Membre3707
28-04-2016 à 10h43
Attention les premiers chargeurs en 36v avaient une led rouge qui s'allumait sur le chargeur en fin de charge (celui que j'ai filé à Olorin par exemple)

Membre3707, 24715 msg. Ce membre n'est plus inscrit.
 Citer Alerter [446391]
Olorin
28-04-2016 à 10h50
heu je ne l'ai jamais vue... elle clignote vert dés que la batterie vient d'être mise, puis vert constant durant la charge, et toujours vert dès que c'est terminé.

Olorin, 1756 msg, 36 ans. Massy (FR-91). [mon blog] Gitane NoCar 2012 16661km / MW-cycle BBS02 48v/750W 5260km
 Citer Alerter [446392]
Membre3707
28-04-2016 à 10h58
C'est parce qu'elle charge mal, du temps ou elle fonctionnait nickel, elle passait au rouge, mais faut dire que c'était dans le cas ou elle restait longtemps sur le chargeur (toute la nuit)

Membre3707, 24715 msg. Ce membre n'est plus inscrit.
 Citer Alerter [446393]
David66
28-04-2016 à 10h59
voila les 4 trames de démarrage "inbitables"
tu as jusqu'à midi pour nous donner ce que ça veut dire
sinon le conseil se réunira ...
et tu seras certainement banni de la secte Cyclurba !
courage Olorin, tu peux le faire
on est tous avec toi ......

P.S. j'aime bien les ... émodéconnes euhh émoticones

David, 182 msg, 59 ans. (FR-66).
 Citer Alerter [446394]

Message modifié le 2016-04-28 13:24:48 par David66.
Membre3707
28-04-2016 à 11h07
Purée ça emmène loin le vélo à assistance électrique....

Membre3707, 24715 msg. Ce membre n'est plus inscrit.
 Citer Alerter [446395]
David66
28-04-2016 à 13h01
et voila les trames entre le moteur et la batterie 36V
le vélo est On mais il ne bouge pas je n'arrive pas à pédaler et faire les mesures en même temps surtout dans mon bureau

# le moteur envoie la trame 1 : $ FF FF 00 C4 3C
# la batterie répond la trame 2 : $ FF FF 05 E4 02 94 64 1E 7F 80

et les deux derniers octets bougent au fil du temps

David, 182 msg, 59 ans. (FR-66).
 Citer Alerter [446411]

Message modifié le 2016-04-28 13:06:43 par David66.
David66
28-04-2016 à 13h23
l'espacement entre les trames est beaucoup plus rapide que sur le chargeur
on a entre 50 et 100 ms au lieu d'une seconde sur le chargeur
Il y a aussi une trame mystère au démarrage


David, 182 msg, 59 ans. (FR-66).
 Citer Alerter [446416]
publicité
28-04-2016 à 13h23
Lien commercial -276-

Olorin
28-04-2016 à 15h50
Je viens de voir tes messages.

Donc.... ok c'est imbitable, mais bon au moins on a quelque chose.

Quand le moteur fonctionne et que les derniers octets bougent, sa doit être le niveau/tension de la batterie (supposition hasardeuse )

Olorin, 1756 msg, 36 ans. Massy (FR-91). [mon blog] Gitane NoCar 2012 16661km / MW-cycle BBS02 48v/750W 5260km
 Citer Alerter [446424]
52 messages.      1 2 3 4 5 6   - Protocole batterie Panasonic 36V - Lu 12721 fois. [18354]
retour en haut de page Messages récents
répondre dans cette discussion
En ce moment sur le tchat
Le 04 à 13h32 Totodav2004 bonjour pour la présentation de l'avancé de mon proto sur base de moteur hoverboard je poste ça ou svp
Le 04 à 16h47 Ptit-philou Ici ? : Véhicules électriques > Trottinettes et véhicules électriques personnels
Le 04 à 16h49 Ptit-philou On a des doublons de messages sur le forum : bug dans la base de données ? "Déjà-vu"
Le 08 à 17h27 Thanda-13 Une lumière bleue fixe ou clignotante à l’avant d’un vélo est-elle interdite ou bien est-elle tolérée .Merci
Le 10 à 08h47 Havoc Je dirais qu'elle est les deux à la fois.

Lien commercial --