Fatal error: Call to undefined function VerifGetPost() in /home/cyclurba/public_html/cyclurba.fr/cache/jccache.php on line 12
Nouvelle discussionNouveau message Derniers messages Recherche forum
199 messages.      5 6 7 8 9 10 11 12 13 14 15   - Openlog, datalogger miniature pour Cycle Analyst v2 et v3 [12923]
Superjc
10-12-2013 à 23h16
Acceder au profil du membre
Gnongris , Je comprends pas ton premier message, si on lit bien le texte anglais c’est la procédure pour remettre à 9600 si tu connais pas le baud rate qui était dedans auparavant
Hors il y a pas de raison que ça se modifie d’autant plus que c’est 9600 par défaut dans le fichier config.txt


Christophe, 3235 msg, 60 ans. Guyancourt (FR-78). [mon blog] 36V 250W VTT bafang swxk 185R MetV and BBS01 Cycloboost
 Citer Alerter [276551]
Jacques74
10-12-2013 à 23h55
Acceder au profil du membre
Ce problème arrive si le rx est relié à la masse lors de la mise sous tension de l'OpenLog
Jai trouvé l'explication au problème. Elle est décrite comme une fonctionnalité de reset du port série de l'OpenLog en début de programme



D'après la doc (et j'utilise ce principe si piloté par un Arduino) pour faire un simple reset c'est pas le Rx qui est utilisé mais la pin GRN

Exemple :
const byte resetOpenLog = 12; // pin 12 sur GRN du module Openlog

//Setup up the serial1 (Leonardo et Micro), reset OpenLog so we know what state it's in, and waits
//for OpenLog to come online and report '< ' that it is ready to receive characters to record

void setupOpenLog(void) {
  Serial1.begin(9600);
  //Reset OpenLog
  digitalWrite(resetOpenLog, LOW);
  delay(100);
  digitalWrite(resetOpenLog, HIGH);

  //Wait for OpenLog to respond with '< ' to indicate it is alive and recording to a file
  // boucle sans fin si erreur !
  while(1) {
   if(Serial1.available())
   if(Serial1.read() == '< ') break;
   }
} // endfunc



Par ailleurs, en connexion directe sur mon CA j'utilise que RX, Gnd et VCC et je ne constate pas de reset après démarrage..
Comment se fait-il que ton RX se connecte à la masse ?
Bizarre ton truc
J'ai l'impression qu'il se met en mode attente de commande et du coup n'enregistre rien !?

Pour ta dernière modif du firmware, dans quelles conditions le CA envoie des trames avec du texte ? (j'en ai encore jamais vu...??)

Anonyme, 18470 msg, (FR).
 Citer Alerter [276555]
publicité
10-12-2013 à 23h55
Creation du fichier https://cyclurba.fr/fichier/pub_log.txt
Blog du magasin VeloEco
Gnongris
11-12-2013 à 11h10
Acceder au profil du membre

Jacques74 a écrit :
Pour ta dernière modif du firmware, dans quelles conditions le CA envoie des trames avec du texte ? (j'en ai encore jamais vu...??)



Si tu as configurer des zones (Preset Cnt dans le menu Setup Presets) à l'aide d'un switch 3 positions sur l'entrée Auxiliaire du CA (il me semble que c'est ton cas) et que tu as défini des courants max ou puissance max, lorsque tu change de zones le paramètre "Lims" prends différentes valeurs. Je n'en connais pas la signification exacte mais elle plante à chaque fois une trame. Sur l'exemple, on en perd beaucoup trop à mon goût.


Gnongris, 292 msg, 53 ans. St Dolay (FR-56).
 Citer Alerter [276577]
Gnongris
11-12-2013 à 12h08
Acceder au profil du membre

Superjc a écrit :
Gnongris , Je comprends pas ton premier message, si on lit bien le texte anglais c’est la procédure pour remettre à 9600 si tu connais pas le baud rate qui était dedans auparavant Hors il y a pas de raison que ça se modifie d’autant plus que c’est 9600 par défaut dans le fichier config.txt



Ce n'est pas la config qui se modifie. Une vidéo rapide expliquera mieux le pépin Entrée non désiré de l'OpenLog dans son mode reset port série. Les commentaires pas très claire mais je pense que le pépin est compréhensible.

Mais à chaque branchement (CA éteint) se fichu openlog rentre dans son mode "reset port série" et la led bleue qui signale la fin de se processus clignote au même rythme que si on enregistrait. Moralité à chaque fois je me fait pièger.

Gnongris, 292 msg, 53 ans. St Dolay (FR-56).
 Citer Alerter [276594]
Jacques74
11-12-2013 à 13h27
Acceder au profil du membre
C'est très clair avec ta vidéo et tes commentaires
On trouve d'ailleurs sur le Github une annonce qui parle de cet ajout (ignoreRX) pour corriger ce problème github.com
Ce problème doit arriver que si on utilise une batterie externe car avec une alim commune CA et Openlog je n'ai jamais constaté de défaut.
Tu as trouvé la parade c'est parfait.

Pour les flag "Lim", effectivement ils sont utilisés lors d'un changement de mode CA v3 avec l'inter 3 positions !
Je ne l'avais pas encore remarqué puisque mes essais ce sont tous réalisés sur un mode unique et sans PAS... merci pour l'info et la modif du firmware pour Logview !
(c'est un peu idiot d'avoir créé une colonne texte, il aurait pu mettre un code en chiffre... )

Anonyme, 18470 msg, (FR).
 Citer Alerter [276612]
Superjc
14-12-2013 à 13h37
Acceder au profil du membre

snickers a écrit :
J'ai pas tester en 36V... Je me suis commandé un openlog, y a plus qu'a...


moi aussi et c’est déjà arrivé
16euros, merci à Silicium81 pour l’info


Christophe, 3235 msg, 60 ans. Guyancourt (FR-78). [mon blog] 36V 250W VTT bafang swxk 185R MetV and BBS01 Cycloboost
 Citer Alerter [277139]
Superjc
14-12-2013 à 19h53
Acceder au profil du membre
Petit test rapide
Openlog + picaxe = ok


Christophe, 3235 msg, 60 ans. Guyancourt (FR-78). [mon blog] 36V 250W VTT bafang swxk 185R MetV and BBS01 Cycloboost
 Citer Alerter [277205]
Superjc
17-12-2013 à 10h37
Acceder au profil du membre
Avant de brancher directement sur le cycleanalyst, J’ai fait un essai :
A l’aide d’un picaxe j’ai simulé des trames cycleanalyst V2 à la fréquence de 1HZ vers lopenlog
Sur l’alim 5V de l’openlog j’ai mis mon multimètre qui donne les mA Max mais pas l’AVG
Tout va bien 2 mA en idle mais j’ai des pointes de consommation max régulières >30mA lors des écritures sur carte microSD (64mB)
Les écritures sont toutes les 1-2 s environ
Faudrait que j’emprunte un multimètre au Taff pour voir la moyenne AVG mais à vue de nez ça semble tourner aux alentours de 6-7mA
Donc trop risqué pour un branchement direct sur le 5V du CA v2


Christophe, 3235 msg, 60 ans. Guyancourt (FR-78). [mon blog] 36V 250W VTT bafang swxk 185R MetV and BBS01 Cycloboost
 Citer Alerter [277683]
Jacques74
17-12-2013 à 15h48
Acceder au profil du membre
D'après la doc et de ce que j'ai pu vérifier, c'est bien ~6mA max (AVG) pendant les phases d’écriture SD et 2 mA au repos.
Sur le CA v3 ça pose pas de problème mais sur le v2 c'est chaud...
Comme j'ai monté maintenant un PAS, je ne vais plus utiliser le 10V Thun mais le VBatt (1A fuse).
J'ai fais des essais avec un simple pont diviseur avec 2 x 3 résistances 0.5W en //. C'est rudimentaire mais ça fonctionne très bien en 36 et 48V !

Anonyme, 18470 msg, (FR).
 Citer Alerter [277714]
publicité
17-12-2013 à 15h48
Creation du fichier https://cyclurba.fr/fichier/pub_log.txt
Superjc
17-12-2013 à 16h29
Acceder au profil du membre
Je pense que mon openlog n’est pas avec la dernière version du soft et J’y connais rien pour upgrader.
Dans le fichier config il y a pas de paramètre après echo (9600,26,3,0,1,1baud,escape,esc#,mode,verb,echo)
Je regarderai ça en janvier 2014 ….


Christophe, 3235 msg, 60 ans. Guyancourt (FR-78). [mon blog] 36V 250W VTT bafang swxk 185R MetV and BBS01 Cycloboost
 Citer Alerter [277724]
199 messages.      5 6 7 8 9 10 11 12 13 14 15   - Openlog, datalogger miniature pour Cycle Analyst v2 et v3 - Lu 115022 fois. [12923]
retour en haut de page Messages récents
Creation du fichier https://cyclurba.fr/fichier/forum_compteur.txt
répondre dans cette discussion
En ce moment sur le tchat
Le 16 à 11h07 Danakone Bonjour,
Est-ce que l'un d'entre vous a déjà utilisé ce chargeur?
cyclurba.fr
Le 16 à 17h12 Havoc Bonjour, la Shoutbox sert à afficher des messages d'information, ça ne sert à rien de poser des questions techniques dans cette fenêtre...
Le 16 à 19h00 Titif Je ne trouve aucunes discussion sur ce sujet, et en cherchant sur le net j'ai réussi a debrider le Nouveau VTT Essentiel Boulanger que je...
Le 16 à 20h49 Havoc Bonsoir, tu pourrais nous présenter ce vélo dans la rubrique [url=https://cyclurba.fr/forum-velo/6/vn-los-assistn-s-motorisn-s.html]VAE[...
Le 18 à 17h26 Phildam bonjour a tous, je cherche la marque du moteur d'origine velowatt belleville 2017 (roue arriere) j'ai chercher sur le forum j'ai pas...

Creation du fichier https://cyclurba.fr/fichier/pub_log.txt
Transformez votre vélo en vélo électrique !

Creation du fichier https://cyclurba.fr/fichier/pub_log.txt
Roofbi, la protection automne-hiver du cycliste

Creation du fichier https://cyclurba.fr/fichier/pub_log.txt

Creation du fichier https://cyclurba.fr/fichier/pub_log.txt
Transformez votre vélo en vélo électrique

Creation du fichier https://cyclurba.fr/fichier/pub_log.txt